ElasticSearch--分布式全文搜索框架

安装

安装elasticsearch其实非常简单,去官网 https://www.elastic.co/downloads/elasticsearch 下载一个(windows)zip,然后解压,进入bin目录下打开cmd运行elasticsearch.bat就可以了,然后在浏览器中输入127.0.0.1:9200就可以看到es的信息了,就是如此简单的一个操作,却在过程中遇到了痛不欲生的坑,首先最最最最重要的一点就是版本,版本这个问题花费了我最多的时间,由于刚刚接触这个框架,下了个最新版,然后在安装ik、集成springboot的时候均出现了版本的问题,经过一番折腾这才知道是版本的原因,首先看看es和springboot和spring Data Elasticsearch三者的版本对应关系如下

Spring Boot Version (x) Spring Data Elasticsearch Version (y) Elasticsearch Version (z)
x <= 1.3.5 y <= 1.3.4 z <= 1.7.2*
x >= 1.4.x 2.0.0 <=y < 5.0.0** 2.0.0 <= z < 5.0.0**

可以看到Spring Data Elasticsearch只支持5.0.0以下版本的elasticsearch,我的springboot是1.5.8而我安装的es是6.1.1所以集成的时候一直报错,而我google了半天,试了各种方法均不成功,结果原来是版本不匹配问题,然后我将es版本降到2.4.0,但是问题又来了,当我在安装ik分词插件的时候发现没有与es2.4.0对应的ik插件,ik与es版本对应关系如下:

IK版本 ES版本
6.x - >主
6.1.1 6.1.1
5.6.4 5.6.4
5.5.3 5.5.3
5.4.3 5.4.3
5.3.3 5.3.3
5.2.2 5.2.2
5.1.2 5.1.2
1.10.6 2.4.6
1.9.5 2.3.5
1.8.1 2.2.1
1.7.0 2.1.1
1.5.0 2.0.0
1.2.6 1.0.0
1.2.5 0.90.x
1.1.3 0.20.x
1.0.0 0.16.2 - > 0.19.0

可以看到,ik没有es2.4.0对应的版本,于是我又妥协,将es版本降到2.3.5(这个表里有ik1.10.6,但是github releases中没有这个版本),然后安装ik,安装ik很简单,下载1.9.5版本的zip解压到es的plugin/ik目录下,然后重新启动es就ok了,但是问题到这里就完了么?当然没有,当我安装好ik之后启动es的时候居然报错了,于是又google,不过这次很快在github上的issues中找到了答案 https://github.com/medcl/elasticsearch-analysis-ik/issues/384,安装目录中不能出现空格,于是将整个es复制出来放在合法的目录中,启动ok,然后安装拼音分词器,2.3.5对应的拼音分词器版本是1.7.5,安装之后启动没问题,总算是安装好了,所以立即得:最合理的elasticsearch版本是2.3.5

init

从头梳理一下应该安装的es版本及各插件的版本,我的版本如下:
elasticsearch(2.3.5) -> ik分词器插件(1.9.5)->拼音分词器插件(1.7.5)
将其打包上传到百度云以免一个一个去下载, 链接: https://pan.baidu.com/s/1pKU9Dvt 密码: xq43
初始化流程已经写在readme.txt中了

学习

学习es最好的方法当然是看官方文档,比较舒服的一点是官方提供了中文文档:

当项目中通过springboot集成ES来使用ES的话,比较幸运的是spring已经做好了很多功能,我们可以轻松使用,通过在pom中引入spring-data-elasticsearch来使用es,如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
<dependencies>
...
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-data-elasticsearch</artifactId>
</dependency>
</dependencies>

<repositories>
<repository>
<id>spring-snapshot</id>
<name>Spring Maven SNAPSHOT Repository</name>
<url>http://repo.springsource.org/libs-snapshot</url>
</repository>
</repositories>

spring-data-elasticsearch的github地址:spring-data-elasticsearch
如何使用spring-data-elasticsearch?
参考官方文档,文档中写的非常清楚,并且有使用例子:

如果只是想简单使用es的话,在了解了es本质是个分布式数据库之后,并且知道相关es概念之后,可以直接阅读spring-data-elasticsearch文档,简单易懂。当然要深入使用还是得去看官方文档!

总结

to be continue…